
Campus for WordPress 

By Charles A Jones - www.themeisland.net 

Instructions on Copying the Demo 

This is an detailed document providing step by step notes on how to install the theme and set the theme 

up exactly like the demo. This set of instructions is geared toward users new to our themes, users new 

to WordPress, and users that want more information on specific steps. If you are looking for the basics, 

feel free to skim the main point here or find a brief guide in Appearance > Theme Options > Quick Start 

Guide.  

Why so many steps? Because you purchased a powerful theme! We want to give you a head start by 

giving you something real to work with, in addition to providing you with some helpful tools that you 

and your clients can use. 

If you can't find the answer or are having trouble, please file a ticket at our dedicated support forum: 

http://themeisland.ticksy.com/ We are here to help and love user feedback.  

Step 1. Theme Installation 

1.1 Download and Upload Theme via the Standard WordPress Zip method or via the FTP Method 

 

It all starts here! Download the theme package from ThemeForest.net > Account > Downloads and 

extract files from the Zip folder.  Then upload the theme files and activate the theme itself. The theme 

files can be uploaded in two ways: 

  

• Standard WordPress Theme Upload: Navigate to Appearance > Add New Themes > Upload. Hit 

“browse”, and select the zipped theme file that you will find in the Theme Zip folder. Hit “Install 

Now” and the theme will be uploaded and installed. 

 

If you run into any issues uploading using the method above, you can use this alternate method: 

• FTP Upload: Using your FTP program, upload the non-zipped Theme Files folder into the /wp-

content/themes/ folder on your server. 

 

Once the theme is uploaded, you need to activate it. Go to Appearance > Themes and activate your 

chosen theme.  

Step 2. Plugin & Widget Installation 

2.1 Upload Plugins and Widgets included with the theme via the Plugins > Add New Directory or via the 

FTP Method. 



2.1.1  This theme comes with several “pre-packaged” plugins that will automatically be uploaded 

along with your theme. Once your theme is activated, you will need to visit your Plugins panel to 

activate them. They include Visual Composer(Premium), Revolution Slider(Premium), 

Jackbox(Premium) and OptionTree.  

2.1.2  We are not including, but suggest these following free plugins that we used in the demo. 

These plugins are not required to make the theme run, just extras, so we don't force activate these: 

Advanced Excerpt, Ajaxy Live Search, Custom sidbars, Contact Form 7, Google News Just Better, 

Image Widget, Recent Posts Widget Extended, Popular Posts Tabbed Widget for Jetpack, Quick Flickr 

Widget, Widget Importer & Exporter, Shortcodes Ultimate, WP-Paginate, and Zilla Shortcodes.  

2.1.2.1  We recommend installing and activating all of the plugins, then if you want to remove 

some that you aren't using you are welcome to. We've had a ton of feedback on this so we are 

trying to a) offer you the user all of the handy tools that we use b) get your site as powerful as 

the demo and c) make the installation process as easy as we can. Doing this step early will help 

when you we import the demo content, options, and widget settings.  

2.1.2.2  Notes on Plugins: We do not provide support for these plugins. If you have questions on 

these plugins we recommend directing your questions to the plugin authors. With that said, if 

you have questions on how we are using them with our theme or need some basic help, feel 

free to ask us. If you notice a bug in any of these please let us know so that we can include a 

patch. If it is a plugin specific bug, we can pull it from our theme and let the plugin author know 

so they can offer support and better their product. 

2.1.2.3  Recommended Plugin Updates: These recommended plugins may need to be updated 

after up activation. Since these plugins are updated regularly, there is simply no way for us to 

keep the theme-download-package up to date with the most recent  versions year round.  

2.1.2.4  Premium Plugin Updates:  The 

Premium plugin versions that we are 

including have been tested and work 

great. If you still want to update these 

just let us know: 

http://themeisland.ticksy.com/faq/1860  

With that, if you run into an issue with 

the versions included, please let us know. 

• Standard WordPress Activation: You can 

install and activate each of these from the 

Plugins > Add New directory, but this will take 

some time since you have to do this one by 

one.  

 • FTP Upload: An easier method is to just 

upload all of them at once via your FTP 

Figure 1 - FTP Upload Files 



connection. Open your FTP connection > navigate to WP Campus/Resources/Plugins folder > Open 

Campus Plugins > highlight all of the plugin folders > and upload them to your WP Content/Plugins 

folder. Then navigate to your WordPress Admin > Plugins panel > select all of the plugins just added 

> and under Bulk Action select Activate.  Finally, if necessary, select these newly activated plugins > 

and under Bulk Action select Update.  

Step 3. Import Demo Content 

3.1  To import the demo content you'll need to upload the Demo-Content.XML file found in: 

Theme-Package-Name/Resources/Theme-Demo-Content/Demo-Content.XML 

3.1.1  This will  load all demo Posts, Pages, and Menu items that the demo uses. This will also import 
some additional items such as contact forms and other items (note that plugins need to be 
installed/activated prior to this file being uploaded to import associated content).  

 
3.2  Use the following steps to import this file:  
 

3.2.1  Navigate to Tools > Import panel and select "WordPress".  
  

3.2.2  You may be prompted to install & activate the WordPress Importer 
plugin if this is your first time. Go ahead and do so, then return to the 
Importer. 

3.2.3  Click "Browse" > navigate and select the provided XML file "Demo-Content.xml" > click 
"Upload file and import" > and when prompted select "Download and import file attachments" and 
hit Submit.  

3.2.4  Wait a few minutes for the process to complete, then you're done! If there are any error 
produced they could be from content that already exists or from missing plugins. This is normal but 
if you are concerned with the results, you can delete all posts/pages/menus (make sure to delete 
them from your trash also) and re-upload the file after reviewing the notes. 

3.3  Review the imported content (optional):  

3.3.1  Visit the Appearances > Menus panel to make sure the menu spaces are saved properly (for 
more on Menus, check out step 8. 

3.3.2  Visit the Pages panel to take a quick peek at the Pages that you imported. 

3.3.3  Visit the Posts panel to take a quick peek at the Posts that you imported. 

3.3.4  At any point, you can delete the Posts, Pages, Menus, and Users that were imported here 
from their respective admin panels. 

Step 4. Import Demo Options and Styles 

http://campus.themeisland.net/wp-admin/import.php
http://campus.themeisland.net/wp-admin/nav-menus.php
http://campus.themeisland.net/wp-admin/edit.php?post_type=page
http://campus.themeisland.net/wp-admin/edit.php


4.1  To import the Demo Theme Options you'll need to upload the text found in the OptionTree-

Options.txt file found in:  

Theme-Package-Name/Resources/Theme-Demo-Content/OptionTree-Layouts.TXT 

4.1.1  This will load all of the options and styles that the demo uses. (You will need to download and 
install the OptionTree plugin for this step).  

 
4.2  Use the following steps to import this file:  
 

4.2.1  Navigate to the OptionTree > Settings panel. 

4.2.2  Then also navigate and open the "OptionTree-Options.txt" file in a text editor. 

4.2.3  Copy the entire code string/content from that .TXT file and paste it into the "Theme Options" 
text field at the bottom of this page. (See Image Below)  

 

4.2.4  Note that some settings may still need to be filled out or adjusted to your specific site (like 
the Slider Shortcode, Categories, and Images), so take a few minutes to review the options and play 
around with it. This import method is a quick way to start, but by no means should it conclude your 
work in the Theme Options panel! 

Step 5. Import Widgets and Sidebar Settings 

5.1  To import the widget and included sidebar settings you'll need to upload the Widgets.WIE file found 

in:  

Theme-Package-Name/Resources/Theme-Demo-Content/Widgets.WIE 

5.1.1  This will load all of the widget and sidebar settings that the demo uses. (You will need to 
download and install the Widget Importer & Exporter plugin for this step).  

 
5.2  Use the following steps to import this file:  

http://campus.themeisland.net/wp-admin/admin.php?page=ot-settings
http://tinyurl.com/d6sajqp


 
5.2.1  Navigate to the Tools > Widget Import/Export panel. 

5.2.2  Click "Browse" > navigate and select the provided WIE file "widgets.wie" > click "Import 
Widgets" 

5.2.3  If there are any error produced they could be from content that already exists or from missing 
plugins. This is normal but if you are concerned with the results, you can re-upload this file again 
after installing/activating any missing plugins. 

5.2.4  Navigate to Appearance > Widgets to review the widgets and sidebar settings uploaded. 

Step 6. Setting The Home Page 

6.1  Assigning the Page 

6.1.1  In your WordPress admin > navigate to in Settings > Reading 

6.1.2 Generally this is set to “Your Latest Posts” by default. To display some custom content on your 

home page (like in the demo), you can assign a custom page under "Front Page displays" > Select "A 

static page" and choose a page from the dropdown for the "Front page" option. 

.  

6.1.3  (Note: Using the Post page option in Settings > Reading will negate all page templates, so it's 
best to leave this blank. For more information on this, check out this link from the WordPress Codex: 
http://codex.wordpress.org/Settings_Reading_Screen  Don't  worry, you'll be able to set this 
functionality and many other options in the page options for each page).  

6.1.4  You can set any page here but for demo purposes, choose "Home Page" from the dropdown.  

6.2  Setting up the Slider 

6.2.1  Open the Revolution Slider Panel > Click Import Slider > Browse > and select the 

homepage_slider.txt file found in Campus WP > Resources > Slider Skeletons folder.  



      

6.2.2  If the slider isn't showing up on the front page, copy the shortcode generated by Revolution 

Slider:  [rev_slider homepage_slider] 

 

Then, navigate to the page you set as your homepage in step 6.1 and insert the shortcode to the 

"Slider Shortcode for Page Header" in the Page Options. 

  

Step 7. Setting Up Your Typography 

7.1  Visit Appearance > Theme Options > Typography and 

select some general font's if you are not currently using 

Typekit or another custom fonts set up.  

7.2   The Demo is utilizing Typekit, and setting up a Typekit account is free and easy. They allow one kit 

with their free account, so this step will walkthough the details of our kit that you can copy:   

7.2.1  Register at https://typekit.com/  and Login to your new account 

7.2.2  Then click Find Fonts at the top right and search "Museo Slab" > Hover over the 

font and click "Create a Kit" > Give it a name and add your domain address (ie. 

campus.themeisland.net) > And click Continue.   

7.2.3  Then with the Kit Editor launched, 

add the following selectors (you should 

be able to just copy/paste them): 

#grid-filter, #grid-filter a.button, 
.highlight-row span, .page-caption, .sf-
menu > li > a strong,  



.sf-menu ul li a, .sf-menu ul li li a, .tk-museo-slab, .wpb_content_element .wpb_accordion_header a,  

.wpb_content_element .wpb_tour_tabs_wrapper .wpb_tabs_nav a, h1, h1 span, h2, h3, h4, h5 

7.2.4  And the following font weights: 300, 300 Italic, 700, 700 Italic 

7.2.5  Then navigate to "Embed Code" at the top right > copy the code provided > navigate to 
Appearance > Theme Options > Typography > and paste/replace the code into the "Additional Fonts: 
Enter a Font Replacement Embed Code" option > Save Changes > and don't forget to hit publish on 
the Kit Editor and give it some time to be processed.  

 

Step 8. Check the Content for Missing Options 

We've now imported the Theme-Options, Plugins, Widgets and the demo Posts and Pages. Some 

settings may not have imported properly though - so it is best to check the pages (especially pages with 

sidebars) and the Theme Options panel for any settings that may have been left blank.  

8.1  Menus 

8.1.1  Next, make sure the Menus were added 

successfully. In most cases, the Menus will import, but 

you must assign then to their Menu Location in the 

Appearances > Menus panel.  

8.2  Page Options 

8.2.1  This usually just includes assigning "Category Filters" on the Blog and Portfolio pages 

8.2.2  And Re-Save pages to load the sidebar options. 

8.3  Custom Sidebars 

8.3.1  If you are using the "Custom sidebars" plugin, you 

need to navigate to Appearance > Custom sidebars and 

select the Default Post/Page Sidebar and click save. This will 

allow you to replace the Default Post/Page Sidebar with 

your own custom sidebars in the page options.  

8.4  Theme Options 



8.4.1  Setting number of columns in the 

Tophat Dropdown by navigating to 

Appearance > Theme Options > Header 

Options 

8.4.2  If the Logo area isn't centered, 

you can set the header layout to 

"Centered" by navigating to 

Appearance > Theme Options > Header 

Options. 

8.5  Layout Builder Templates

 

8.5.1  Last, we should note that although all of the 

theme pages using the Layout Builder import 

seamlessly, but the template/layout options do not.  

With that said, you can easily save new templates by 

creating a page and saving the element layout with their 

Template Option.  

Step 9. Have Fun! 

At this point you should have a fairly decent looking front-end site. That's good! But you won't really be 

able to call it your own until you start adding your own content (posts, pages, etc.) and filling out your 

own Theme Options. This might take an afternoon or two for new users, but we're confident that you'll 

be rocking out awesome sites with this theme in no time. 

Again if you run into any issues or have some feedback for our development team, please let us know: 

http://themeisland.ticksy.com/ 

Thanks for Reading! 

Charles Jones 


